ACPI OFF with supermicro server rack

Hello,
I have a problem in the almalinux logs of my server and I have the solution but I can’t find the directory I have to disable the acpi in the grub but I can’t see where it is because I have a super micro rack server

ACPI OFF RED Hat website

here are my problems

APEI: Can not request [mem 0xbf7aa760-0xbf7aa7b3] for APEI BERT registers
ERST: Failed to get Error Log Address Range.

Typically you alter GRUB configurations indirectly by modifying the /etc/default/grub file.

There are files in /etc/grub.d that are used during every rebuild of your /boot/grub2/grub.cfg (caused by a grub2-mkconfig execution manually or by a kernel update automatically) will continue to include your expected configuration.

Also, you may need to look into /boot/grub2 instead. The /boot/grub path referenced in the Red Hat article is definitely a typo.

Finally, if you are running a system under EFI, you have to confirm your changes are within the grub.cfg file found in a totally different place. This I am not confident on, but I do sincerely believe that grub.cfg configurations are stored in a different place on EFI systems separately from BIOS systems.

Hello,
I can’t figure out how to do this and I’m afraid to screw up my server lol
I would like to know how to activate the 4 cores of my processor please
my CPU :
Processeur Intel® Xeon® X3430
Thank you in advance

The Red Hat’s documentation that you did link to is about RHEL 6. The RHEL 6 had legacy GRUB.

AlmaLinux 8 is clone of RHEL 8. AlmaLinux has GRUB2. Hence the instructions to configure it do not match.

GRUB2 has its configuration in either /boot/grub2/grub.cfg (if system uses legacy BIOS mode) or /boot/efi/EFI/almalinux/grub.cfg (if EFI us in use). Only one of them should exists.
Files /etc/grub2.cfg and /etc/grub2-efi.cfg are symbolic links to those files.

First thing is thus to figure out which do you have. Run as root:

ls -l /etc/grub2*

Next thing is to look at the configuration. Run:

cat /etc/default/grub

My system has:

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="resume=UUID=47..98 nouveau.modeset=0 rd.driver.blacklist=nouveau plymouth.ignore-udev"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true

If I did want the acpi=off, then I would edit the GRUB_CMDLINE_LINUX to be:

GRUB_CMDLINE_LINUX="resume=UUID=47..98 acpi=off nouveau.modeset=0 rd.driver.blacklist=nouveau plymouth.ignore-udev"

However, before you do any edits, I’d recommend that you reboot and in the interactive GRUB menu, during boot, edit the kernel command-line parameters; add the acpi=off, boot system, and check your logs whether the parameter has desired effect. The changes you do interactively are not persistent.

When you are sure that you want acpi=off on every boot, then edit the /etc/default/grub and then run

grub2-mkconfig -o the_grub.cfg_in_your_system

The command creates content of grub.cfg and writes it to file that the -o specifies. Without -o filename the grub2-mkconfigwrites to stdout.

[EDIT]:
Have you set in EFI that CPU can use all cores? It tends to be the default, but for some reason server BIOS/EFI usually has option to limit number of cores.

I did what you said

ACPI has been disabled or is not available on this hardware. This may result in a single cpu boot, incorrect PCI IRQ routing, or boot failure.

I have put in the settings of the bios that all the cores are activated I just found the problem concerning the processor to change the setting and put on all the cores

now I have a problem with my Bond0 in Bond 0 it should contain :
enp2s0
enp3s0
enp4s0
enp5s0
because I have 4 Ethernet ports now it detects 5 when there is no 6 or other no 6 or other so I removed them from my bond0 because they are deactivated to put them back it gives me this error message

Error changing net interface name 'enp6s0' to 'enp5s0': File exists

No suitable device found for this connection (device enp2s0 not available because profile is not compatible with device (mismatching interface name)).

ifconfig :

bond0: flags=5187<UP,BROADCAST,RUNNING,MASTER,MULTICAST>  mtu 1500
        inet 10.10.20.100  netmask 255.255.255.0  broadcast 10.10.20.255
        inet6 fe80::30ae:ec2f:11e1:845f  prefixlen 64  scopeid 0x20<link>
        ether 00:25:90:31:f9:80  txqueuelen 1000  (Ethernet)
        RX packets 23179  bytes 27954017 (26.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 14638  bytes 2516947 (2.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp2s0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 00:25:90:31:f9:80  txqueuelen 1000  (Ethernet)
        RX packets 12237  bytes 14181965 (13.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 7747  bytes 1494270 (1.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xfb3e0000-fb400000  

enp3s0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 00:25:90:31:f9:80  txqueuelen 1000  (Ethernet)
        RX packets 16804  bytes 14875248 (14.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13683  bytes 4000375 (3.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  memory 0xfb4e0000-fb500000  

enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 00:25:90:31:f9:82  txqueuelen 1000  (Ethernet)
        RX packets 563  bytes 36944 (36.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18  memory 0xfb5e0000-fb600000  

enp6s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 00:25:90:31:f9:83  txqueuelen 1000  (Ethernet)
        RX packets 9925  bytes 2653139 (2.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10471  bytes 5643911 (5.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 19  memory 0xfb6e0000-fb700000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 20813  bytes 6742006 (6.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 20813  bytes 6742006 (6.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I managed to fix the problem with “sudo nmtui” now my bond0 networks unfortunately an Ethernet is no longer called enp2s0 but 6 now so after time it works but I have a problem

The site that allowed me to solve the problem of my network

ACPI has been disabled or is not available on this hardware.  This may result in a single cpu boot, incorrect PCI IRQ routing, or boot failure.

Initially:

Then you did completely disable ACPI. Now you have:

The latter message is correct: you did (successfully) disable ACPI.

The question is: was that the only/best solution to the original problem?
I don’t know.

PS.
Config that attempts to rename persistently named interfaces does not sound right.
Red Hat has instructions for configuring bonded connections: Chapter 13. Configuring network bonding Red Hat Enterprise Linux 8 | Red Hat Customer Portal
Teaming is newer alternative for bonding: Chapter 12. Configuring network teaming Red Hat Enterprise Linux 8 | Red Hat Customer Portal

I noticed that my server is not shutting down properly and is stuck on this

It might very well be that kernel cannot send the hardware the “shut off” signal because ACPI is completely disabled.

so it would be a bad idea to have disabled

I have a question, do I have to put it back the way it was before