AlmaLinux oVirt Install Help

So I am trying to install oVirt Engine on AlmaLinux and so far I am unable to. I have followed Installing oVirt as a standalone Engine with local databases | oVirt and get the error “Failed to execute stage ‘Environment setup’: No supported package manager found in your system” when I run
engine-setup
I know that this issue has been fixed by version 4.5 of ovirt but I can’t get the beta repository setup correctly. I created a script to setup the repos but it just doesn’t work autiboys-linux/AlmaLinux-oVirt.sh at master · czadikem/autiboys-linux · GitHub . What am I doing wrong?

It seems RockyLinux works with just the install Installing oVirt as a standalone Engine with local databases | oVirt though. So what needs to be added or installed on AlmaLinux.

What does Rocky Linux have that AlmaLinux doesn’t? I love Alma so far but if I can’t get oVirt to work I will have to use Rocky.

That does sound like the ‘engine-setup’ of oVirt does look at distro version strings, and recognizes only two out of three. That is, the way it does “package manager detection” apparently does not simply check: “Do we have DNF, Yum, Apt, …”