Application terminated due to some permission error on libcrypt.so

Hi Experts.,

Need your kind help on below issue that we are experiencing in our product with Alma Linux 8.5 environment.

Java Application terminated with some access error on libcrypt.so.
When application crashed, it created hs_err_pid805779.log file (also attached the same file).
In this log, we can see below line
“siginfo: si_signo: 11 (SIGSEGV), si_code: 2 (SEGV_ACCERR)”

Here SEGV_ACCERR means “Invalid permissions for mapped object.” (this is from man pages)

In the same file under stack info, we can see below lines
“Stack: [0x00007fc0d17da000,0x00007fc0d18db000], sp=0x00007fc0d18d5828, free space=1006k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [libcrypt.so.1.1.0+0x1825]”.

Considering both things we can assume that the reason for restart is access restriction for libcrypt.so library.

Also, below is the result of ‘ls -ltr’ on the libcrypto.so file from the same VM.
-rwxr-xr-x. 1 root root 144568 May 11 2019 /usr/lib64/libcrypt.so.1.1.0
lrwxrwxrwx. 1 root root 17 May 11 2019 /usr/lib64/libcrypt.so.1 → libcrypt.so.1.1.0

Could you please help us understand the reason why access is restricted for this library.

Thanks,
Kiran

SELinux or buffer overflow?

what does sestatus return? what about ls -lZ /usr/lib64/libcrypt.so.1.1.0 ?

have you tried setenforce 0 then running the program? maybe using strace?

what user is the program running as - and what java version/vendor?

have you tried upgrading to 8.7?

log doesn’t seem to be attached.