Can't install gcc-toolset-12-gcc-gfortran on ppc64le

Starting a few days ago, gcc-toolset-12-gcc-gfortran can’t be installed anymore on ppc64le

#12 25.11 Error: 
901#12 25.11  Problem: cannot install the best candidate for the job
902#12 25.11   - nothing provides gcc-toolset-12-libquadmath-devel = 12.1.1-3.4.el8_7 needed by gcc-toolset-12-gcc-gfortran-12.1.1-3.4.el8_7.ppc64le
903#12 25.11 (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

It seems to be related to an update that appeared in the mirrors on Jan 13th.
Indeed, the updated package is not present in the ppc64le mirror (Index of /almalinux/8/AppStream/ppc64le/os/Packages/) while it seems to be available for x86_64 (Index of /almalinux/8/AppStream/x86_64/os/Packages/).

I thought I’d report this here before opening a bug in case I missed something.

See 8.7 upgrade problem, it may be the same issue.

Thanks for the suggestion but it does not appear to be the same:

Matt@MacBook-Pro manylinux % docker run -it --rm quay.io/pypa/manylinux_2_28_ppc64le:latest  
WARNING: The requested image's platform (linux/ppc64le) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
[root@47a40f97ab9e /]# dnf clean all
0 files removed
[root@47a40f97ab9e /]# dnf update
AlmaLinux 8 - BaseOS                                                                                                                                                 497 kB/s | 3.4 MB     00:06    
AlmaLinux 8 - AppStream                                                                                                                                              569 kB/s | 9.3 MB     00:16    
AlmaLinux 8 - Extras                                                                                                                                                  21 kB/s |  18 kB     00:00    
AlmaLinux 8 - PowerTools                                                                                                                                             492 kB/s | 2.4 MB     00:04    
Last metadata expiration check: 0:00:01 ago on Sat 28 Jan 2023 08:36:38 AM UTC.
Error: 
 Problem 1: cannot install the best update candidate for package gcc-toolset-12-gcc-gfortran-12.1.1-3.2.el8.ppc64le
  - nothing provides gcc-toolset-12-libquadmath-devel = 12.1.1-3.4.el8_7 needed by gcc-toolset-12-gcc-gfortran-12.1.1-3.4.el8_7.ppc64le
 Problem 2: cannot install the best update candidate for package libgfortran-8.5.0-15.el8.alma.ppc64le
  - nothing provides libquadmath = 8.5.0-16.el8_7.alma needed by libgfortran-8.5.0-16.el8_7.alma.ppc64le
 Problem 3: package gcc-toolset-12-libquadmath-devel-12.1.1-3.2.el8.ppc64le requires gcc-toolset-12-gcc = 12.1.1-3.2.el8, but none of the providers can be installed
  - cannot install both gcc-toolset-12-gcc-12.1.1-3.4.el8_7.ppc64le and gcc-toolset-12-gcc-12.1.1-3.2.el8.ppc64le
  - cannot install the best update candidate for package gcc-toolset-12-libquadmath-devel-12.1.1-3.2.el8.ppc64le
  - cannot install the best update candidate for package gcc-toolset-12-gcc-12.1.1-3.2.el8.ppc64le
 Problem 4: problem with installed package gcc-toolset-12-libquadmath-devel-12.1.1-3.2.el8.ppc64le
  - package gcc-toolset-12-libquadmath-devel-12.1.1-3.2.el8.ppc64le requires gcc-toolset-12-gcc = 12.1.1-3.2.el8, but none of the providers can be installed
  - cannot install both gcc-toolset-12-gcc-12.1.1-3.4.el8_7.ppc64le and gcc-toolset-12-gcc-12.1.1-3.2.el8.ppc64le
  - package gcc-toolset-12-gcc-c++-12.1.1-3.4.el8_7.ppc64le requires gcc-toolset-12-gcc = 12.1.1-3.4.el8_7, but none of the providers can be installed
  - cannot install the best update candidate for package gcc-toolset-12-gcc-c++-12.1.1-3.2.el8.ppc64le
 Problem 5: problem with installed package gcc-toolset-12-gcc-gfortran-12.1.1-3.2.el8.ppc64le
  - package gcc-toolset-12-gcc-gfortran-12.1.1-3.2.el8.ppc64le requires gcc-toolset-12-gcc = 12.1.1-3.2.el8, but none of the providers can be installed
  - cannot install both gcc-toolset-12-gcc-12.1.1-3.4.el8_7.ppc64le and gcc-toolset-12-gcc-12.1.1-3.2.el8.ppc64le
  - package gcc-toolset-12-gcc-c++-12.1.1-3.4.el8_7.ppc64le requires gcc-toolset-12-gcc = 12.1.1-3.4.el8_7, but none of the providers can be installed
  - problem with installed package gcc-toolset-12-gcc-c++-12.1.1-3.2.el8.ppc64le
  - package gcc-toolset-12-gcc-c++-12.1.1-3.2.el8.ppc64le requires gcc-toolset-12-libstdc++-devel = 12.1.1-3.2.el8, but none of the providers can be installed
  - cannot install both gcc-toolset-12-libstdc++-devel-12.1.1-3.4.el8_7.ppc64le and gcc-toolset-12-libstdc++-devel-12.1.1-3.2.el8.ppc64le
  - cannot install the best update candidate for package gcc-toolset-12-libstdc++-devel-12.1.1-3.2.el8.ppc64le
  - nothing provides gcc-toolset-12-libquadmath-devel = 12.1.1-3.4.el8_7 needed by gcc-toolset-12-gcc-gfortran-12.1.1-3.4.el8_7.ppc64le
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@47a40f97ab9e /]# 

The package appears to have been built looking at AlmaLinux Build System but is not available in the repo.

You shoud create a ticket in https://bugs.almalinux.org/ that package
gcc-toolset-12-libquadmath-devel-12.1.1-3.4.el8_7.ppc64le is missing from repo.