Disable Network Manager Connection Check

Dear Support.
I need disable one Function into the Network Manager. My problem is when i remove the cable from Interface Ethernet , the state this is interface is Down and remove the IP this Interface ethernet.
When I put the cable back the interface is UP.

So, i disable the Network Manager after boot the system with the command and problem solved.
#systemctl stop NetworkManager

But, if disable NetworkManger from Boot all the Interface don´t go UP.

My Question: How can i disable the connection check into the NetworkManager ?

There is package: NetworkManager-config-server
If you do install it, then the behaviour of NetworkManager changes.
NetworkManager does not react to link state changes in RHEL7, 8 Server - Red Hat Customer Portal writes:

This package modifies the default NetworkManager behaviour to:

  1. Disable auto-configuration of all interfaces by enabling the no-auto-default option
  2. Disable monitoring of link state by enabling the ignore-carrier option

Is that the effect that you actually desire?

1 Like


Look the first Image. My IP is 172.16.2.255. Is i remove the cagle from Inteface the NetworksManager remove this IP because don´t cable connect.

I instaled the packege NetworkManager-config-server-1.32.10-5.el8_5.noarch
and put the conf /etc/NetworkManager/NetworkManager.conf the value for variable ignore-carrier=yes and don´t work. O put the ignore-carrier=no and problem persist.

[main]
#plugins=ifcfg-rh
ignore-carrier=yes

I need remove the cacle and NetworkManager dont remove the IP.
Any Ideas ?

Your IP address is 172.16.2.225. The 172.16.2.255 is the broadcast address of subnet 172.16.2.0/24.

Remove the files/modifications that you have added manually. Just installing the NetworkManager-config-server did add all the files/configs that you should need.

Then restart the NetworkManager.service

After these, what is the output of:

NetworkManager --print-config

Sorry for delay and I made a mistake when entering the IP address.
So i remove ignore-carrier=yes these lines into the /etc/NetworkManager/NetworkManager.conf. Look Bellow my file:

Configuration file for NetworkManager.

See “man 5 NetworkManager.conf” for details.

The directories /usr/lib/NetworkManager/conf.d/ and /run/NetworkManager/conf.d/

can contain additional configuration snippets installed by packages. These files are

read before NetworkManager.conf and have thus lowest priority.

The directory /etc/NetworkManager/conf.d/ can contain additional configuration

snippets. Those snippets are merged last and overwrite the settings from this main

file.

The files within one conf.d/ directory are read in asciibetical order.

If /etc/NetworkManager/conf.d/ contains a file with the same name as

/usr/lib/NetworkManager/conf.d/, the latter file is shadowed and thus ignored.

Hence, to disable loading a file from /usr/lib/NetworkManager/conf.d/ you can

put an empty file to /etc with the same name. The same applies with respect

to the directory /run/NetworkManager/conf.d where files in /run shadow

/usr/lib and are themselves shadowed by files under /etc.

If two files define the same key, the one that is read afterwards will overwrite

the previous one.

#[main]
#plugins=ifcfg-rh
#ignore-carrier=yes

[logging]

When debugging NetworkManager, enabling debug logging is of great help.

Logfiles contain no passwords and little sensitive information. But please

check before posting the file online. You can also personally hand over the

logfile to a NM developer to treat it confidential. Meet us on #nm on freenode.

Please post full logfiles except minimal modifications of private data.

You can also change the log-level at runtime via

$ nmcli general logging level TRACE domains ALL

However, usually it’s cleaner to enable debug logging

in the configuration and restart NetworkManager so that

debug logging is enabled from the start.

You will find the logfiles in syslog, for example via

$ journalctl -u NetworkManager

Note that debug logging of NetworkManager can be quite verbose. Some messages

might be rate-limited by the logging daemon (see RateLimitIntervalSec, RateLimitBurst

in man journald.conf). Please disable rate-limiting before collecting debug logs.

#level=TRACE
#domains=ALL

=====================================================

[root@Amep NetworkManager]# NetworkManager --print-config

NetworkManager configuration: /etc/NetworkManager/NetworkManager.conf (lib: 00-server.conf)

[main]

plugins=ifcfg-rh

rc-manager=symlink

auth-polkit=true

dhcp=internal

iwd-config-path=

no-auto-default=*
ignore-carrier=no

[connectivity]
enabled=false

[logging]

backend=journal

audit=false

no-auto-default file “/var/lib/NetworkManager/no-auto-default.state”

[root@Amep NetworkManager]#

Dear Suport, above is the output of the command