KDE broken repositories

Greetings,

I have Almalinux 9 installed as my main OS.

Gnome and Xfce work perfectly.

However, KDE plasma gives me the following errors when using: sudo dnf -y groupinstall “KDE Plasma Workspaces” “base-x”.

Error:
Problem 1: cannot install the best candidate for the job

  • nothing provides qt5-qtbase(x86-64) = 5.15.3 needed by kf5-akonadi-server-22.04.1-1.el9.next.x86_64
  • nothing provides libQt5Core.so.5(Qt_5.15.3_PRIVATE_API)(64bit) needed by kf5-akonadi-server-22.04.1-1.el9.next.x86_64
  • nothing provides libQt5Sql.so.5(Qt_5.15.3_PRIVATE_API)(64bit) needed by kf5-akonadi-server-22.04.1-1.el9.next.x86_64
    Problem 2: cannot install the best candidate for the job
  • nothing provides qt5-qtbase(x86-64) = 5.15.3 needed by plasma-workspace-5.24.6-2.el9.next.x86_64
    Problem 3: package sddm-breeze-5.24.6-2.el9.next.noarch requires plasma-workspace = 5.24.6-2.el9.next, but none of the providers can be installed
  • cannot install the best candidate for the job
  • nothing provides qt5-qtbase(x86-64) = 5.15.3 needed by plasma-workspace-5.24.6-2.el9.next.x86_64
    Problem 4: package plasma-desktop-5.24.6-1.el9.next.x86_64 requires plasma-workspace >= 5.24, but none of the providers can be installed
  • cannot install the best candidate for the job
  • nothing provides qt5-qtbase(x86-64) = 5.15.3 needed by plasma-workspace-5.24.6-2.el9.next.x86_64
    Problem 5: package kwin-5.24.6-1.el9.next.x86_64 requires kwin-wayland = 5.24.6-1.el9.next, but none of the providers can be installed
  • cannot install the best candidate for the job
  • nothing provides qt5-qtbase(x86-64) = 5.15.3 needed by kwin-wayland-5.24.6-1.el9.next.x86_64
  • nothing provides libQt5Core.so.5(Qt_5.15.3_PRIVATE_API)(64bit) needed by kwin-wayland-5.24.6-1.el9.next.x86_64
  • nothing provides libQt5Gui.so.5(Qt_5.15.3_PRIVATE_API)(64bit) needed by kwin-wayland-5.24.6-1.el9.next.x86_64
    Problem 6: package kf5-akonadi-server-mysql-22.04.1-1.el9.next.x86_64 requires kf5-akonadi-server(x86-64) = 22.04.1-1.el9.next, but none of the providers can be installed
  • cannot install the best candidate for the job
  • nothing provides qt5-qtbase(x86-64) = 5.15.3 needed by kf5-akonadi-server-22.04.1-1.el9.next.x86_64
  • nothing provides libQt5Core.so.5(Qt_5.15.3_PRIVATE_API)(64bit) needed by kf5-akonadi-server-22.04.1-1.el9.next.x86_64
  • nothing provides libQt5Sql.so.5(Qt_5.15.3_PRIVATE_API)(64bit) needed by kf5-akonadi-server-22.04.1-1.el9.next.x86_64
    Problem 7: problem with installed package plasma-workspace-libs-5.23.5-2.el9.x86_64
  • package plasma-workspace-libs-5.23.5-2.el9.x86_64 requires plasma-workspace-common = 5.23.5-2.el9, but none of the providers can be installed
  • cannot install both plasma-workspace-common-5.24.6-2.el9.next.x86_64 and plasma-workspace-common-5.23.5-2.el9.x86_64
  • package plasma-workspace-geolocation-libs-5.24.6-2.el9.next.x86_64 requires plasma-workspace-common = 5.24.6-2.el9.next, but none of the providers can be installed
  • package plasma-workspace-geolocation-5.24.6-2.el9.next.x86_64 requires plasma-workspace-geolocation-libs(x86-64) = 5.24.6-2.el9.next, but none of the providers can be installed
  • cannot install the best candidate for the job
  • nothing provides libQt5Gui.so.5(Qt_5.15.3_PRIVATE_API)(64bit) needed by plasma-workspace-libs-5.24.6-2.el9.next.x86_64
  • nothing provides libQt5WaylandClient.so.5(Qt_5.15.3_PRIVATE_API)(64bit) needed by plasma-workspace-libs-5.24.6-2.el9.next.x86_64
    (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

i have tried ‘–nobest’, ‘–best allowerasing’, ‘–skip-broken’, ‘–allowerasing’ ,
and more. and non seem to be working.

any advise or potential fixes will be a ton of help!

thank you.
Jason

On Alma 9:

$ dnf -q --enablerepo=epel list kf5-akonadi-server qt5-qtbase
Installed Packages
qt5-qtbase.x86_64                        5.15.2-29.el9           @AppStream
Available Packages
kf5-akonadi-server.x86_64                21.08.3-1.el9           epel      
qt5-qtbase.i686                          5.15.2-29.el9           appstream

What you try to install is not kf5-akonadi-server-21.08.3-1.el9.x86_64, but kf5-akonadi-server-22.04.1-1.el9.next.x86_64

Do you perhaps have repository “epel-next” defined? The EPEL Next is for CentOS Stream, not for RHEL and distros derived from RHEL.

Greetings, Jlehtone.

Yes I “epel-next” defined

the above command, gives the following error:

dnf -q --enablerepo=epel list kf5-akonadi-server qt5-qtbase
Installed Packages
qt5-qtbase.x86_64 5.15.2-29.el9 @AppStream
Available Packages
kf5-akonadi-server.x86_64 21.08.3-1.el9 epel
qt5-qtbase.i686 5.15.2-29.el9 appstream
Installed Packages
kf5-akonadi-server.x86_64 21.08.3-1.el9 @epel
qt5-qtbase.x86_64 5.15.2-29.el9 @AppStream
Available Packages
kf5-akonadi-server.x86_64 22.04.1-1.el9.next epel-next
qt5-qtbase.i686 5.15.2-29.el9 appstream
bash: Installed: command not found…
bash: qt5-qtbase.x86_64: command not found…
bash: Available: command not found…
bash: kf5-akonadi-server.x86_64: command not found…
bash: qt5-qtbase.i686: command not found…

Thank you.

The error is probably that you did copy-paste multiple lines, rather than just the command:

dnf -q --enablerepo=epel list kf5-akonadi-server qt5-qtbase

Nevertheless, you should not have ‘epel-next’. That is not for AlmaLinux 9. Disable that repo and clean cache:

sudo dnf config-manager --disable epel-next
sudo dnf --enablerepo=* clean all

(Better yet, remove the definition of epel-next in the manner that matches the method that you did use to define it.)

Greetings, Jlehtone.

Thank you very much for your help!

It worked You are fantastic!

Have a fantastic day!

Kind regards,
Jason