Problem with nvidia

Dear All,

I noticed that I have a problem with nvidia with Alma8.9
when I try to run this:
dnf config-manager --add-repo http://developer.download.nvidia.com/compute/cuda/repos/x86_64/cuda-rhel8.repo
I receive this:
error:configuration of repo failed

“404, no such URL”

I have Ansible playbook for AlmaLinux 9 that would essentially look like this for AL8:

- hosts: all
  tasks:
  - name: Define CUDA repository
    ansible.builtin.yum_repository:
      name:        "cuda-rhel8-x86_64"
      file:        "cuda-rhel8"
      description: "cuda-rhel8-x86_64"
      baseurl:     "https://developer.download.nvidia.com/compute/cuda/repos/rhel8/x86_64"
      gpgkey:      "https://developer.download.nvidia.com/compute/cuda/repos/rhel8/x86_64/D42D0685.pub"
      gpgcheck:    true
      enabled:     true

If I start browsing from Index of /compute/cuda/repos/rhel8/x86_64 then I do find a *.repo file.
Note the differences between your URL and what I would use for AlmaLinux 8 (if I would dnf config-manager --add-repo):

http://developer.download.nvidia.com/compute/cuda/repos/x86_64/cuda-rhel8.repo
https://developer.download.nvidia.com/compute/cuda/repos/rhel8/x86_64/cuda-rhel8.repo

thanks @jlehtone for your helps.
Now, I tried to reinstall it with alma 9.3 (Actually this problem happened to me when I tried to solve the gtk +3.2 issue. (at that time, I forgot what I did, the history I logged is in linux and I do not have access now) and when I updated from alma9.2 to alma9.3, alma 9.3 had the same problem, but I could work with previous kernel of alma9.2 without any problem. I think this time also the problem would be the same.

now, I want to access the terminal to work on the issue, previously I could have access using alt+ctrl+f3, but now I cannot, is there anyway?

All The Best

I think the reason might be that I did this:
yum update --nogpgcheck

now, I could enter alma9.3 by using following:
1- edit grub by pressing e on alma9.3 at the start of boot
2- add modprobe.blacklist=nouveau at the end of line starting with linux in grub.
(I think for present I might need to add the same in CMDLINE_LINUX_DEFAULT in grub file in /etc/default till I install nvidia again.)

All The Best

thanks @jlehtone , now I could enter alma9.3 without nvidia,
now I installed all nvidia packages I guess, but still when I remove “rd.driver.blacklist=nouveau” from GRUB_CMDLINE_LINUX, still seems monitor is not recognized and I have only lower resolution:

sudo dnf module list nvidia-driver
Last metadata expiration check: 0:14:04 ago on Mon 15 Jan 2024 03:53:48 PM JST.
cuda-rhel9-x86_64
Name Stream Profiles Summary
nvidia-driver latest default [d], fm, Nvidia driver for latest bran
ks, src ch
nvidia-driver latest-dkms [d][e] default [d] [i], Nvidia driver for latest-dkms
fm, ks branch
nvidia-driver open-dkms default [d], fm, Nvidia driver for open-dkms b
ks, src ranch
nvidia-driver 515 default [d], fm, Nvidia driver for 515 branch
ks, src
nvidia-driver 515-dkms default [d], fm, Nvidia driver for 515-dkms br
ks anch
nvidia-driver 515-open default [d], fm, Nvidia driver for 515-open br
ks, src anch
nvidia-driver 520 default [d], fm, Nvidia driver for 520 branch
ks, src
nvidia-driver 520-dkms default [d], fm, Nvidia driver for 520-dkms br
ks anch
nvidia-driver 520-open default [d], fm, Nvidia driver for 520-open br
ks, src anch
nvidia-driver 525 default [d], fm, Nvidia driver for 525 branch
ks, src
nvidia-driver 525-dkms default [d], fm, Nvidia driver for 525-dkms br
ks anch
nvidia-driver 525-open default [d], fm, Nvidia driver for 525-open br
ks, src anch
nvidia-driver 530 default [d], fm, Nvidia driver for 530 branch
ks, src
nvidia-driver 530-dkms default [d], fm, Nvidia driver for 530-dkms br
ks anch
nvidia-driver 530-open default [d], fm, Nvidia driver for 530-open br
ks, src anch
nvidia-driver 535 default [d], fm, Nvidia driver for 535 branch
ks, src
nvidia-driver 535-dkms default [d], fm, Nvidia driver for 535-dkms br
ks anch
nvidia-driver 535-open default [d], fm, Nvidia driver for 535-open br
ks, src anch
nvidia-driver 545 default [d], fm, Nvidia driver for 545 branch
ks, src
nvidia-driver 545-dkms default [d], fm, Nvidia driver for 545-dkms br
ks anch
nvidia-driver 545-open default [d], fm, Nvidia driver for 545-open br
ks, src anch

Hint: [d]efault, [e]nabled, disabled, [i]nstalled

Also, I have this message at the start of boot:
integrity: problem loading x.509 certificate -126.

Also, I installed nvidia using this website as follows:

mokutil --sb-state
sudo dnf config-manager --set-enabled crb
sudo dnf install
https://dl.fedoraproject.org/pub/epel/epel-release-latest-9.noarch.rpm
https://dl.fedoraproject.org/pub/epel/epel-next-release-latest-9.noarch.rpm

sudo dnf config-manager --add-repo http://developer.download.nvidia.com/compute/cuda/repos/rhel9/$(uname -i)/cuda-rhel9.repo

sudo dnf install kernel-headers-$(uname -r) kernel-devel-$(uname -r) tar bzip2 make automake gcc gcc-c++ pciutils elfutils-libelf-devel libglvnd-opengl libglvnd-glx libglvnd-devel acpid pkgconfig dkms

sudo dnf module install nvidia-driver:latest-dkms

All The Best