Unable to mount exFAT volumes

First of all, I just wanted to say “Thank you” for picking up where Red Hat/CentOS left off. I migrated my server to CentOS 8 a few months ago and I was disappointed (to say the least) when I saw that support was being dropped. AlmaLinux has been a great replacement so far.

Unfortunately, I’ve been unable to mount exFAT volumes and I can’t seem to find the ‘exfat-utils’ package in the available repositories. I get the following error when attempting to mount:

mount: /mnt/externalhdd: unknown filesystem type ‘exfat’.

These are the repositories I have enabled:

$ yum repolist 
repo id                                                                                          repo name
appstream                                                                                        AlmaLinux 8 - AppStream
baseos                                                                                           AlmaLinux 8 - BaseOS
epel                                                                                             Extra Packages for Enterprise Linux 8 - x86_64
epel-modular                                                                                     Extra Packages for Enterprise Linux Modular 8 - x86_64
extras                                                                                           AlmaLinux 8 - Extras
powertools                                                                                       AlmaLinux 8 - PowerTools

There is a ‘exfatprogs.x86_64’ available and I see that ‘mkfs.exfat’ is installed, but unfortunately these aren’t what I need. Can someone provide some insight as to what I’m missing or when the necessary package/support will be added? Thanks!

2 Likes

It seems that I needed the package ‘fuse-exfat.x86_64’, which I got from the rpmfusion repositories. I was able to mount my exFAT volume after installing that package.

Thanks @Marvin and thank you for the kind words. We are glad you are having a good time with the OS. I am glad you were able to solve your problem.

Please feel free to join us on chat too if you wish https://chat.almalinux.org.

@Marvin Thanks for posting the solution here. I’ve just put my camera’s SD card into the machine and Alma couldn’t mount it (though CentOS 7 + whatever could). I’ve enabled the repositories and now can see the photos.

1 Like