USB stick to install almalinux 8.6

When using USB stick to install almalinux 8.6, the install source option does not detect the image file, prompting that a chosen ISO file is required(error 1), but the ISO file for the DVD version is too large to be copied to the USB stick(The boot disk is in fat32 format)(error2).
So, it only supports virtual machines to install?

This is what I see, if I look at AlmaLinux 9 USB stick:

$ lsblk -o name,size,type,fstype,UUID
NAME          SIZE TYPE FSTYPE  UUID
sda          14.6G disk iso9660 2022-05-25-15-29-15-00
├─sda1        7.5G part iso9660 2022-05-25-15-29-15-00
└─sda2          7M part vfat    A71C-806F

That is dvd iso, that I have written to USB with dd

How do you write the ISO into the USB?

First, follow @jlehtone 's advice. He’s an expert.

If you really have a USB stick that’s too small for the image, can’t you obtain a larger USB stick? They’re pretty cheap these days. Your other alternative is to do a network installation if you have a decent internet connection. Slightly confusingly, the network installation ISO is called AlmaLinux-9.0-x86_64-boot.iso. You start the installation in the normal way, but then configure the network connection and give the Alma repositories as the source rather than the USB.

Thanks for your reply,I have used so many tools, such as Universal-USB-Installer-2.0.1.4a (try unlisted linuxOS),unetbootin-windows-702,balenaEtcher-Portable-1.5.115_2 and UltraISO. Now I’m wondering if the problem is caused by the LABEL value, you know, the USB stick label is only 11 characters, so the complete ‘AlmaLinux-8-6-x86_64-dvd’ will be truncated to ‘AlmaLinux-8’, tomorrow I’m going to modify the LABEL in syslinux.cfg to try it out.

Well, it’s not that I don’t have a large capacity USB stick (in fact, my USB stick capacity is 64GB), but the limit of 4G for a single file in FAT32 format. At the moment, there is no network configuration, and considering the speed of the network, I prefer local installation.thanks.

Right, in that case follow @jlehtone 's advice. Many USB installers try to “improve” the process and in doing so mess it up. General advice here, and on the previous CentOS fora, is to use dd and remember to direct the output to the device, not to a filesystem. I’d expect a command along the lines of:

  # dd if=<path to ISO file> of=/dev/sdk

Obviously replace “/dev/sdk” with the device name of the USB! (“Check, check and check again”!)

that sounds like you’re trying to copy the ISO file to a fat32 formatted usb stick.

you don’t want to do that. you want to dd the iso file to the raw usb stick - which will remove the fat32 partition altogether, but as @MartinR says, be careful with the device names, it will never be /dev/sda for example.

Never say “never”. :slight_smile: My lsblk output above genuinely has the USB as “sda”, because my system disk is /dev/nvme*

The https://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/ writes:

Unlike tools which simply use the DD (Copy and Convert) command to directly burn an ISO to a USB flash drive, UUI includes several other methods that natively allow you to continue using your removable device for storage purposes, whilst including a “Try via DD” option. The DD method of copying, also known as Data Destroyer works by overwriting the entire file system, making the device appear as a CD/DVD which is limited to the size of the ISO file.

By that description the Universal-USB-Installer should be able to write image to stick just like dd would.

Thank you all, the problem has been solved, it does require a computer with linux OS, and the image can be burned by dd command in order to install successfully, which means that the image burning tool is not supported by the current windows platform.