Update problem -

After I use “yum update && yum upgrade” I get this error:

Error:
Problem 1: cannot install the best update candidate for package kf5-sonnet-core-5.105.0-1.el9.x86_64

  • nothing provides libaspell.so.15()(64bit) needed by kf5-sonnet-core-5.108.0-1.el9.x86_64 from epel
    Problem 2: package kf5-sonnet-ui-5.108.0-1.el9.x86_64 from epel requires kf5-sonnet-core(x86-64) = 5.108.0-1.el9, but none of the providers can be installed
  • cannot install the best update candidate for package kf5-sonnet-ui-5.105.0-1.el9.x86_64
  • nothing provides libaspell.so.15()(64bit) needed by kf5-sonnet-core-5.108.0-1.el9.x86_64 from epel
    Problem 3: package texmaker-1:5.1.3-5.el9.x86_64 from @System requires libQt5Core.so.5(Qt_5.15.3_PRIVATE_API)(64bit), but none of the providers can be installed
  • cannot install both qt5-qtbase-5.15.9-7.el9.x86_64 from appstream and qt5-qtbase-5.15.3-1.el9.x86_64 from @System
  • cannot install the best update candidate for package texmaker-1:5.1.3-5.el9.x86_64
  • cannot install the best update candidate for package qt5-qtbase-5.15.3-1.el9.x86_64
    Problem 4: problem with installed package texmaker-1:5.1.3-5.el9.x86_64
  • package texmaker-1:5.1.3-5.el9.x86_64 from @System requires libQt5Core.so.5(Qt_5.15.3_PRIVATE_API)(64bit), but none of the providers can be installed
  • package texmaker-1:5.1.3-5.el9.x86_64 from epel requires libQt5Core.so.5(Qt_5.15.3_PRIVATE_API)(64bit), but none of the providers can be installed
  • cannot install both qt5-qtbase-5.15.9-7.el9.x86_64 from appstream and qt5-qtbase-5.15.3-1.el9.x86_64 from @System
  • package keepassxc-2.7.6-1.el9.x86_64 from epel requires qt5-qtbase(x86-64) = 5.15.9, but none of the providers can be installed
  • cannot install the best update candidate for package keepassxc-2.7.5-1.el9.x86_64
    (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

Please, help me to resolve this!

It’s fine. I found solution. I will install Ubuntu. With CentOS and Alma always problems.