Update Package Script Errors

Hi everyone, we are running cPanel on AlmaLinux 11.110.0.6 and are getting the below errors when attempting to update packages. Any ideas?

[2023-05-25 21:15:40 +1000] Processing: Running update-packages
[2023-05-25 21:15:40 +1000] - Processing command /usr/local/cpanel/scripts/update-packages
[2023-05-25 21:15:40 +1000] [/usr/local/cpanel/scripts/update-packages] checkyum version 22.3 (excludes: bind-chroot)
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] Last metadata expiration check: 1:13:44 ago on Thu May 25 20:01:58 2023.
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] Error:
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] Problem 1: package shim-x64-15.6-1.el8.alma.1.x86_64 requires almalinux(kernel-sig-key) >= 202303, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - cannot install the best update candidate for package shim-x64-15.6-1.el8.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package kernel-core-4.18.0-477.10.1.el8_8.x86_64 is filtered out by exclude filtering
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] Problem 2: package grub2-efi-x64-1:2.02-148.el8.alma.x86_64 requires /boot/efi/EFI/almalinux/shimx64.efi, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package grub2-efi-x64-1:2.02-148.el8.alma.x86_64 conflicts with shim-x64 <= 15.6-1.el8.alma provided by shim-x64-15.6-1.el8.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package shim-x64-15.6-1.el8.alma.1.x86_64 requires almalinux(kernel-sig-key) >= 202303, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - cannot install the best update candidate for package grub2-efi-x64-1:2.02-142.el8_7.3.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package kernel-core-4.18.0-477.10.1.el8_8.x86_64 is filtered out by exclude filtering
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] Problem 3: package shim-x64-15.6-1.el8.alma.x86_64 requires /boot/efi/EFI/almalinux/grubx64.efi, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package grub2-efi-x64-1:2.02-148.el8.alma.x86_64 conflicts with shim-x64 <= 15.6-1.el8.alma provided by shim-x64-15.6-1.el8.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package grub2-efi-x64-1:2.02-142.el8_7.3.alma.x86_64 requires grub2-common = 1:2.02-142.el8_7.3.alma, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - problem with installed package shim-x64-15.6-1.el8.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - cannot install both grub2-common-1:2.02-148.el8.alma.noarch and grub2-common-1:2.02-142.el8_7.3.alma.noarch
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package shim-x64-15.6-1.el8.alma.1.x86_64 requires almalinux(kernel-sig-key) >= 202303, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - cannot install the best update candidate for package grub2-common-1:2.02-142.el8_7.3.alma.noarch
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package kernel-core-4.18.0-477.10.1.el8_8.x86_64 is filtered out by exclude filtering
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] Problem 4: package grub2-efi-x64-1:2.02-148.el8.alma.x86_64 requires /boot/efi/EFI/almalinux/shimx64.efi, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package grub2-efi-x64-1:2.02-148.el8.alma.x86_64 conflicts with shim-x64 <= 15.6-1.el8.alma provided by shim-x64-15.6-1.el8.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - problem with installed package grub2-efi-x64-1:2.02-142.el8_7.3.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package grub2-efi-x64-1:2.02-142.el8_7.3.alma.x86_64 requires grub2-tools = 1:2.02-142.el8_7.3.alma, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package grub2-tools-efi-1:2.02-148.el8.alma.x86_64 obsoletes grub2-tools < 1:2.02-148.el8.alma provided by grub2-tools-1:2.02-142.el8_7.3.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package shim-x64-15.6-1.el8.alma.1.x86_64 requires almalinux(kernel-sig-key) >= 202303, but none of the providers can be installed
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - cannot install the best update candidate for package grub2-tools-efi-1:2.02-142.el8_7.3.alma.x86_64
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] - package kernel-core-4.18.0-477.10.1.el8_8.x86_64 is filtered out by exclude filtering
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)
[2023-05-25 21:15:44 +1000] [/usr/local/cpanel/scripts/update-packages] (XID xg4k84) “/usr/bin/yum” reported error code “1” when it ended:
[2023-05-25 21:15:44 +1000] E [/usr/local/cpanel/scripts/update-packages] The “/usr/local/cpanel/scripts/update-packages” command (process 3117252) reported error number 1 when it ended.

Just as a heads up, we’re also experiencing this issue on our Almalinux 8 / CL8 machine. This is a recently provisioned server.

/usr/local/cpanel/scripts/update-packages

checkyum version 22.3 (excludes: bind-chroot)
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:25:18 ago on Fri May 26 21:49:20 2023.
Error:
Problem 1: package libstdc+±devel-8.5.0-16.el8_7.alma.x86_64 requires libstdc++(x86-64) = 8.5.0-16.el8_7.alma, but none of the providers can be installed

  • cannot install both libstdc+±8.5.0-18.el8.alma.x86_64 and libstdc+±8.5.0-16.el8_7.alma.x86_64
  • cannot install the best update candidate for package libstdc+±devel-8.5.0-16.el8_7.alma.x86_64
  • cannot install the best update candidate for package libstdc+±8.5.0-16.el8_7.alma.x86_64
    Problem 2: package libtiff-devel-4.0.9-26.el8_7.x86_64 requires libtiff(x86-64) = 4.0.9-26.el8_7, but none of the providers can be installed
  • cannot install both libtiff-4.0.9-27.el8.x86_64 and libtiff-4.0.9-26.el8_7.x86_64
  • cannot install the best update candidate for package libtiff-devel-4.0.9-26.el8_7.x86_64
  • cannot install the best update candidate for package libtiff-4.0.9-26.el8_7.x86_64
    Problem 3: package libxml2-devel-2.9.7-15.el8_7.1.x86_64 requires libxml2(x86-64) = 2.9.7-15.el8_7.1, but none of the providers can be installed
  • cannot install both libxml2-2.9.7-16.el8.x86_64 and libxml2-2.9.7-15.el8_7.1.x86_64
  • cannot install the best update candidate for package libxml2-devel-2.9.7-15.el8_7.1.x86_64
  • cannot install the best update candidate for package libxml2-2.9.7-15.el8_7.1.x86_64
    Problem 4: libgomp-8.5.0-16.el8_7.alma.i686 has inferior architecture
  • package gcc-8.5.0-16.el8_7.alma.x86_64 requires libgomp = 8.5.0-16.el8_7.alma, but none of the providers can be installed
  • cannot install both libgomp-8.5.0-18.el8.alma.x86_64 and libgomp-8.5.0-16.el8_7.alma.x86_64
  • cannot install the best update candidate for package libgomp-8.5.0-16.el8_7.alma.x86_64
  • cannot install the best update candidate for package gcc-8.5.0-16.el8_7.alma.x86_64
    Problem 5: package ghostscript-9.27-4.el8.x86_64 requires libgs(x86-64) = 9.27-4.el8, but none of the providers can be installed
  • cannot install both libgs-9.27-6.el8.x86_64 and libgs-9.27-4.el8.x86_64
  • cannot install the best update candidate for package libgs-9.27-4.el8.x86_64
  • cannot install the best update candidate for package ghostscript-9.27-4.el8.x86_64
    Problem 6: package net-snmp-agent-libs-1:5.8-25.el8_7.1.x86_64 requires net-snmp-libs(x86-64) = 1:5.8-25.el8_7.1, but none of the providers can be installed
  • cannot install both net-snmp-libs-1:5.8-27.el8.x86_64 and net-snmp-libs-1:5.8-25.el8_7.1.x86_64
  • cannot install the best update candidate for package net-snmp-libs-1:5.8-25.el8_7.1.x86_64
  • cannot install the best update candidate for package net-snmp-agent-libs-1:5.8-25.el8_7.1.x86_64
    Problem 7: package perl-4:5.26.3-421.el8.x86_64 requires perl-interpreter(x86-64) = 4:5.26.3-421.el8, but none of the providers can be installed
  • cannot install both perl-interpreter-4:5.26.3-422.el8.0.1.x86_64 and perl-interpreter-4:5.26.3-421.el8.x86_64
  • cannot install the best update candidate for package perl-interpreter-4:5.26.3-421.el8.x86_64
  • cannot install the best update candidate for package perl-4:5.26.3-421.el8.x86_64
    Problem 8: package perl-devel-4:5.26.3-421.el8.x86_64 requires perl-libs(x86-64) = 4:5.26.3-421.el8, but none of the providers can be installed
  • cannot install both perl-libs-4:5.26.3-422.el8.0.1.x86_64 and perl-libs-4:5.26.3-421.el8.x86_64
  • cannot install the best update candidate for package perl-libs-4:5.26.3-421.el8.x86_64
  • cannot install the best update candidate for package perl-devel-4:5.26.3-421.el8.x86_64
    Problem 9: perl-libs-4:5.26.3-421.el8.i686 has inferior architecture
  • package perl-utils-5.26.3-421.el8.noarch requires perl-libs = 4:5.26.3-421.el8, but none of the providers can be installed
  • cannot install both perl-libs-4:5.26.3-422.el8.0.1.x86_64 and perl-libs-4:5.26.3-421.el8.x86_64
  • package perl-Errno-1.28-422.el8.0.1.x86_64 requires perl-libs(x86-64) = 4:5.26.3-422.el8.0.1, but none of the providers can be installed
  • cannot install the best update candidate for package perl-utils-5.26.3-421.el8.noarch
  • cannot install the best update candidate for package perl-Errno-1.28-421.el8.x86_64
    Problem 10: package bind-lite-devel-32:9.11.36-5.el8_7.2.x86_64 requires libxml2-devel(x86-64), but none of the providers can be installed
  • package libxml2-devel-2.9.7-15.el8_7.1.x86_64 requires libxml2(x86-64) = 2.9.7-15.el8_7.1, but none of the providers can be installed
  • package libxml2-devel-2.9.7-15.el8.x86_64 requires libxml2(x86-64) = 2.9.7-15.el8, but none of the providers can be installed
  • cannot install both libxml2-2.9.7-16.el8.x86_64 and libxml2-2.9.7-15.el8_7.1.x86_64
  • cannot install both libxml2-2.9.7-16.el8.x86_64 and libxml2-2.9.7-15.el8.x86_64
  • package python3-libxml2-2.9.7-16.el8.x86_64 requires libxml2(x86-64) = 2.9.7-16.el8, but none of the providers can be installed
  • cannot install the best update candidate for package python3-libxml2-2.9.7-15.el8_7.1.x86_64
  • cannot install the best update candidate for package bind-lite-devel-32:9.11.36-5.el8_7.2.x86_64
    (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)
    (XID zgnbm3) “/usr/bin/yum” reported error code “1” when it ended:

You need to check your excludes for the kernel. Yum shouldn’t be excluding kernel updates and trying to update grub2/shim etc. This is likely the root of the issue.

What excludes do you show configured for yum?

Are you running a base Alma system, or is it running the Cloudlinux OS?

If you’ve got CL installed, then its pretty much a separate OS at that point so you’ll want to reach out to them regarding any issues you may have.

1 Like

Yes it’s CloudLinux 8 in my case Daniel. Thank you.

No worries, I’d reach out to CL about that one, it could be a localized issue to their repo or similar but your issue and the original posters issue differ quite a bit, but with CL in the mix not much we can do here. I do know their repos can be fussy sometimes from experiences we’ve had in the past.

Hi Daniel,

In my case its just base cPanel DNS only without CL.

The excludes I presume are the base ones cPanel have applied. Here is the output of the excludes configured:

exclude=bind-chroot dovecot* exim* filesystem p0f php* proftpd* pure-ftpd*

@DanielP

Bloatedstoat was able to resolve the issue with CL support after raising a support case. Not sure if this helps to resolve the issue in my case though…

“Thank you for your time. The issue was with this automatically added repository:
repo.cloudlinux.com_cloudlinux_8_BaseOS_x86_64_os_
It was causing the conflicts due to having outdated packages (because this is the BaseOS repo, which is for unregistered users).
I removed the repo file, and “yum” can now complete the update”

I would do the following to see if something is mucked up, or if cPanel’s scripts are somehow blocking more than it should be.

dnf clean all
dnf update kernel

That will force a new pull of data from the repositories and just update the kernel which seems to be excluded for some reason.

Hi Daniel,

It looks like this has resolved the issue. Thank you :slight_smile:

Ill post on the cPanel forums, hopefully their support monitors this and corrects the configuration for excluding kernel updates.